Author Topic: FBOOT17 Issues - SOLVED  (Read 2123 times)

0 Members and 1 Guest are viewing this topic.

Offline LukeTopic starter

  • Jr. Member
  • **
  • Posts: 7
  • Helpful? 0
« on: June 25, 2009, 06:57:31 AM »
Hi all. I'm a beginner and I'm having some issues.  I've been working through the axon getting started tutorial, and I'm getting stuck at running FBOOT17.exe to get my code onto the chip.

When I run FBOOT17.exe, I get a popup message that says "The system cannot open COM3 port requested by the application - Close or Ignore"

I am running Windows XP service pack 3. I know it's recommended to downgrade to Service Pack 2 when using FBOOT17.exe, but this is all I have available for the time.

I'm wondering if I am missing something simple, so I'll write out the steps I do to run it.

I have verified that the USB cable is connected to both the PC and my axon microcontroller, and I've checked my hardware manager to make sure that I am in fact using COM3..  The axon microcontroller is off to start. The name of my app is "TS". Once I navigate the projects directory, I execute:

$ FBOOT17.exe -b115200 -c3 -pTS.hex -vTS.hex

I then get a spinning pipe. Sometimes, (like 1 in 25) I'll turn on the axon microcontroller and everything will work. Usually what happens is I get that popup message before I can even turn the microcontroller on.

Is there an additional step that I am missing that will make this work consistently? Or am I doing something wrong all together?

Any help would be appreciated. Even if it is just a link to somewhere else I can ask this question.

Thanks you.
« Last Edit: June 25, 2009, 04:40:05 PM by Luke »

Offline LukeTopic starter

  • Jr. Member
  • **
  • Posts: 7
  • Helpful? 0
Re: FBOOT17 Issues - SOLVED
« Reply #1 on: June 25, 2009, 04:39:51 PM »
It's taken a little while, but I've gotten my hands on a version of Windows XP that does not have Service Pack 3 already installed. (My installation disk already has service pack 3).  Using Windows XP with service pack 2 solved my problem.

Since I noticed there was very little documentation on this error, I'd like to add:  You can also get this error message when another program is connected to (and thus locking) the COM you are using.  For example, having a HyperTerminal connected to COM3 to display output will need to be disconnected before attempting to use fboot17.
« Last Edit: June 26, 2009, 09:01:32 AM by Luke »

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,696
  • Helpful? 173
    • Society of Robots
Re: FBOOT17 Issues - SOLVED
« Reply #2 on: June 27, 2009, 08:27:51 PM »
I know you got it solved, but for anyone else that finds this thread here are some tips:



Get Your Ad Here