go_away

Author Topic: Help. New to AVR Studio, can't step through code during simulation.  (Read 1896 times)

0 Members and 1 Guest are viewing this topic.

Offline madsci1016Topic starter

  • Contest Winner
  • Supreme Robot
  • ****
  • Posts: 1,450
  • Helpful? 43
Hi everyone,

I just got my Axon last week I have many projects lined up for it. I am new to using AVR Studio and can't seem to figure this out.

I would like to step through my code during simulation and watch the various registers change to see if it is functioning correctly. My code compiles with no errors nor warnings. When I start debug mode ( debug -> start debugging) i get the following message:

"Coordinator: The object file does not contain source code information"

And it will only step through the machine code in memory, not the source file.

I also cannot insert breakpoints in my source code, it claims it can't link the source code to a memory address.

I followed everything in the SoR tutorial when starting to program, and i am using the makefile from that tutorial. I made sure the project name and target where the same name.

What am i missing. Can you not step through source code for debugging?

An .elf is being created by the makefile with the same name as the project.

Offline jaime

  • Jr. Member
  • **
  • Posts: 30
  • Helpful? 1
Re: Help. New to AVR Studio, can't step through code during simulation.
« Reply #1 on: August 26, 2009, 07:09:34 AM »
You may need to turn on debugging information.  Look and see if you're passing -g to the compiler.  I looked at doing this once, but I thought the simulator did not support the ATmega640.

You can discover more information aboug gcc's debugging options here:

http://gcc.gnu.org/onlinedocs/gcc/Debugging-Options.html

Good luck!
jaime

 


Get Your Ad Here

data_list