go_away

Author Topic: BOT 3.1 is alive!!!!!!  (Read 2058 times)

0 Members and 1 Guest are viewing this topic.

Offline aventgpsTopic starter

  • Jr. Member
  • **
  • Posts: 21
  • Helpful? 0
BOT 3.1 is alive!!!!!!
« on: October 17, 2009, 08:30:29 AM »
[youtube]nZMZfvfOqNw[/youtube]

arduino controlled.......

first proyect...
« Last Edit: October 17, 2009, 08:33:28 AM by aventgps »

Offline galannthegreat

  • Supreme Robot
  • *****
  • Posts: 615
  • Helpful? 4
  • Blue-Lensed Blue LEDs?! What?! Impossible!!
Re: BOT 3.1 is alive!!!!!!
« Reply #1 on: October 17, 2009, 11:58:37 AM »
Nice work, and congrats on that!
Kurt

Offline Joker94

  • Supreme Robot
  • *****
  • Posts: 1,119
  • Helpful? 26
Re: BOT 3.1 is alive!!!!!!
« Reply #2 on: October 17, 2009, 07:43:02 PM »
Another nice robot to hit the forums, well done.

Offline aventgpsTopic starter

  • Jr. Member
  • **
  • Posts: 21
  • Helpful? 0
Re: BOT 3.1 is alive!!!!!!
« Reply #3 on: October 18, 2009, 12:18:02 AM »
thanks, now i installed a parallax ping on it, made it work allready and  avoid obstacles, but..... here is the problem.

i installed the ping on a servo, so the idea, is to make it take a decition on where to go, based on the parallax ping data...

if it finds a, obstacle it must stop, look aside, then the other side and then choose where to go with the diferent distance infotmation....

did i explain myself???




i can barelly write codes, but i have managed to make it do almost everything i want.


here is the servo bus i had to do..




Offline Joker94

  • Supreme Robot
  • *****
  • Posts: 1,119
  • Helpful? 26
Re: BOT 3.1 is alive!!!!!!
« Reply #4 on: October 18, 2009, 01:30:40 AM »
Well i am not the best coder but i have found that starting my code off by writing a few lines, test it, write some more,test it and so on has been the best approach i have found. For me it has been easir to trouble shoot and fix wgere i have gone wrong.

And i also read through alot of open source code to see where to start.

Good luck. Remember there are hundreds of people that will be happy to help.

Offline dayhkr

  • Jr. Member
  • **
  • Posts: 13
  • Helpful? 0
Re: BOT 3.1 is alive!!!!!!
« Reply #5 on: November 01, 2009, 06:16:24 AM »
Very cool how long did it take you to get your system up and running?


Great job

Offline aventgpsTopic starter

  • Jr. Member
  • **
  • Posts: 21
  • Helpful? 0
Re: BOT 3.1 is alive!!!!!!
« Reply #6 on: November 03, 2009, 06:00:45 PM »
like two days.

 


Get Your Ad Here