Software > Software

Webbotlib Studio FBoot only works the first time!

<< < (5/6) > >>

WLSBoot can now be downloaded from here:
NB For the Axon(s) you need the UART 1 version.

Hero I:
No success.

1) I downloaded WLSboot ( from

Type = WLSBoot
MCU = ATMega640
Speed = 16MHz
UART = 1
BOOTSZ = 512W_7E00

2) I used my AVR Dragon to program and verify WLSBoot_atmega640_Uart1_16MHz.hex

3) I launched WLS and burned the project to the board with the following settings...

Programmer: WLSBoot
COM Port: COM4
Baud Rate: 115200

No matter how many times I try, I'm not getting any success.  :(

I'm running out of options.

I'm willing to loan you my Axon II just to rule out the board.

Hm - I'm also running out of suggestions  :)

--- Quote ---I'm willing to loan you my Axon II just to rule out the board.
--- End quote ---
Not that simple. I'm based in the UK - think you're East Coast - so on top of postage there is customs duty as well. Note I'm just a SoR member like you - I don't make the Axon boards!

Only thing that may be worth knowing is the logging on the WLS Output tab as well as your USB sniffing log. I can then try to work out what's going on.

If all else fails then I could drive your Dragon either via AvrStudio tools or directly via AvrDude (although the latter clobbers the Jungo USB drivers in Atmel Studio - which can be re-installed). Probably need a new thread for this - or an off line chat. Mainly coz I don't have a Dragon. So would need to work together to get something that works.
Given your problems so far then I probably need to buy a Dragon - ie works for me but not you!

 [edit] Just 'gone mad' and ordered a Dragon You could also try dropping the baud rate right down. If that works then increase it till it breaks. Can't give you a 'number' as it depends on how fast your laptop/pc is.

Hero I:
I tried dropping the baud rate down to its lowest level and still no luck.

I then installed WLS 1-14 and tried the "AVR Dragon (Atmel AVR Studio)" option and it works every time I tried it. I'm happy with this setup and will continue to develop using this method.

I bought an Axon, and electronic interface to program it, but never could. I gave up and went to raspberry pi. I always liked the Axon, but never had any luck with programming it.


[0] Message Index

[#] Next page

[*] Previous page

Go to full version