go_away

Author Topic: Recompiling the Webbotlib libraries  (Read 1327 times)

0 Members and 1 Guest are viewing this topic.

Offline SoundDiverTopic starter

  • Beginner
  • *
  • Posts: 5
  • Helpful? 0
Recompiling the Webbotlib libraries
« on: March 06, 2011, 10:04:09 PM »
Stepping through the code in the debugger is a pain since the file paths from the original compilation are expected. (C:\eclipse\workspace\webbotclibrary sound familiar?)

Is there a makefile, AVRStudio project, or plain ol' instructions anywhere for reproducing libWebbot-ATMega640.a on my local machine?

Thanks.

Offline Webbot

  • Expert Roboticist
  • Supreme Robot
  • *****
  • Posts: 2,165
  • Helpful? 111
    • Webbot stuff
Re: Recompiling the Webbotlib libraries
« Reply #1 on: March 07, 2011, 12:51:16 PM »
AVRStudio debugger should then allow you to locate the diretory where you've got WebbotLib source code installed. You can do that without recompiling anything.

The debugger is always a bit flakey since the WebbotLib code is built using -Os optimisation. If you recompile it yourself with, say, no optimisation -O0 then the debugger is better but the code will be much bigger. Also note that the AVRStudio debugger has got loads of bugs - for example some of the timers (cant remember if its 3, 4 or 5) - never generate any interrupts.

If you really need to recompile then I'd take a backup of the original .a files first. Dunk has done a tutorial on recompiling Version 1.xx here:  http://www.societyofrobots.com/member_tutorials/node/382
Webbot Home: http://webbot.org.uk/
WebbotLib online docs: http://webbot.org.uk/WebbotLibDocs
If your in the neighbourhood: http://www.hovinghamspa.co.uk

 


Get Your Ad Here

data_list