go away spammer

Author Topic: AVR Studio SP1 and 3  (Read 1935 times)

0 Members and 1 Guest are viewing this topic.

Offline CanabotsTopic starter

  • Contest Winner
  • Robot Overlord
  • ****
  • Posts: 245
  • Helpful? 6
  • It's not a bug, it's a feature!
    • Salmigondis Tech
AVR Studio SP1 and 3
« on: November 15, 2011, 07:33:07 PM »
I'm setting up all the software to program my Axon on a new computer.

When installing AVR Studio, I download and install 4.19, as that seems to be the newest setup. However, I just get redirected to a different page for both the SP1 and SP3 links, should I just ignore them?

Thanks.
My robotics, electronics, software, or other stuff blog:
www.saltech.wordpress.com

Offline Gertlex

  • Supreme Robot
  • *****
  • Posts: 763
  • Helpful? 24
  • Nuclear Engineer ยท Roboticist
    • Index of Oddities
Re: AVR Studio SP1 and 3
« Reply #1 on: November 15, 2011, 10:54:53 PM »
You're probably fine with 4.19. I'm not sure what I'm using on my laptop (desktop is 4.18, but I don't actually use the desktop for robot coding)... but I do have the two service pack .exe's saved, and can upload them if it turns out they're needed.
I

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,703
  • Helpful? 173
    • Society of Robots
Re: AVR Studio SP1 and 3
« Reply #2 on: November 16, 2011, 10:34:19 AM »
hmmmm it appears that they removed v4.18 and the service packs, and replaced it with just v4.19.

I haven't tried v4.19 yet, but let us know if it gives you any trouble.

edit: hmmmm I also just noticed they now offer an AVR tool chain installer as well:
http://www.atmel.com/dyn/resources/prod_documents/avr-toolchain-installer-3.3.0.710-win32.win32.x86.exe

Again, I haven't tried it, but if anyone does feel free to comment on it.
« Last Edit: November 16, 2011, 10:40:04 AM by Admin »

Offline CanabotsTopic starter

  • Contest Winner
  • Robot Overlord
  • ****
  • Posts: 245
  • Helpful? 6
  • It's not a bug, it's a feature!
    • Salmigondis Tech
Re: AVR Studio SP1 and 3
« Reply #3 on: November 17, 2011, 05:06:22 PM »
I've dug in a bit more the past couple days. Found something describing it's 4.18 with all 3 SPs combined. I haven't had to chance to try it out yet, though based on that information, I'll say it will work great!

Thanks
My robotics, electronics, software, or other stuff blog:
www.saltech.wordpress.com

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,703
  • Helpful? 173
    • Society of Robots
Re: AVR Studio SP1 and 3
« Reply #4 on: November 27, 2011, 09:18:56 AM »
I gave the AVR tool chain installer, but it breaks with WebbotLib. Don't bother with it for now.

 


Get Your Ad Here

data_list