Electronics > Electronics

Cerebellum Problems again.


Ok while setting up my cerebleum for PWM I mad pin 6 of port c an out put.
Those of you who know what I'm talking about (have done this or have seen it done) know how bad this.
Yea I was in too much of a hurry to really scrutinize my code.

Any who my question is about the jumpers. I've gone through the whole "put the emergency juper here and program through firm ware prompt things" but i'm not getting any prompt form my board when i try the emergency jumper.......

I hope some one has some hints.

DISCLAIMER: if you think you can just go to the web site and figure it out, be my guess but I've already speent 4 hours trying to fix this and don't think I've missed any thing. but ....... if you really feel like spending a couple of hours in a haze (I know it seems simple but DON'T try to testing this mishap with your own board).

http://www.botrics.com/support/cereb/manual/chapter2/2-3-pitfalls.html is where it starts.
The thing is when you really get down to it, what jumper are you suposed to do and how are you suposed to reprogram it. I've tried every thing from updating my firmware to manualy programing through the serieal port after trying many combinations of the PGM and I2C jumper.

Has any one worked with Cerbellums alot and knows what I'm talking about or am I in the dark with a posibley faulty board?

I am assuming you already tried the manual programming recovery method?

And it still wont let you program normally after removing your jumpers?

I have never actually done this before so I really cant help much.

Worse case scenario, all you need to do is just buy a new PIC and swap out the old one in your cerebellum. I think they just cost a few dollars and it only takes like 5 seconds to do so it isn't too big a deal.

If still no luck, you should contact the people at botrics.


--- Quote ---Hi Jesse,

The gurus suggest using teraterm to reflash your cerebellum.  The directions:

1:  Setup teraterm using the settings described here:
2: Turn on Cerebellum
3: Insert emergency jumper
4: After you see the "Emergency Jumper Inserted" message, follow the
prompt and remove it.
5: You then enter programming mode by pressing "p <enter>" and then
you can send the file (make sure you have the line delays set in

This should work.  If not, the super emergency method is to carefully
remove the 16f877 using a small screwdriver.  Open teraterm and enter
programming mode.  Once you are in programming mode, hot-plug the
16f877 back into the socket.  You want to be very careful to push it
straight down, as while the risk of damage is low, there is a risk.
Then send the HEX file to Cerebellum.

If these directions don't work be sure to let me know and describe any
serial output from the Cerebellum.

 - Chris Atwood
--- End quote ---

I think I was doing it somewhat wrong but we'll see....
I thought of buying a new chip too....not a bad idea to have around either I guess

The real problem is that on their website it says to never make c6 an output because it is the serial Rx line.
This clearly contradicts the PIC16F877 datasheet and thier own diagram.
The real Rx line is c7 while c6 is the Tx line.

Be forwarned! ;)


[0] Message Index

Go to full version