go_away

Author Topic: servo's will only go to one position  (Read 1398 times)

0 Members and 1 Guest are viewing this topic.

Offline scottad73Topic starter

  • Jr. Member
  • **
  • Posts: 24
  • Helpful? 0
servo's will only go to one position
« on: October 07, 2010, 09:19:02 AM »
some background info, I fried the USB converter on the axon2. No matter which way I change my code I can't get any servo, or 360 mod servo, to goto more than one position, or direction. I have tried inverting the servo using the webbotlib Project Design program, tried changing actsetspeed from MAX to Min and still the servo goes to the same position every time. The code worked before I fried the servo.  I have also tried using different pin outs.

Thanks for your help.

Offline Razor Concepts

  • Supreme Robot
  • *****
  • Posts: 1,856
  • Helpful? 53
    • RazorConcepts
Re: servo's will only go to one position
« Reply #1 on: October 07, 2010, 10:20:56 AM »
So are you using an external programmer to flash the code?

Offline knossos

  • Robot Overlord
  • ****
  • Posts: 278
  • Helpful? 14
Re: servo's will only go to one position
« Reply #2 on: October 07, 2010, 10:23:57 AM »
Can you change the code to do something else (like a simple blink LED program) and upload it to make sure you are able to upload correctly?
"Never regret thy fall,
O Icarus of the fearless flight
For the greatest tragedy of them all
Is never to feel the burning light."
 
— Oscar Wilde

Offline scottad73Topic starter

  • Jr. Member
  • **
  • Posts: 24
  • Helpful? 0
Re: servo's will only go to one position
« Reply #3 on: October 07, 2010, 02:06:46 PM »
I am using the Pololu USB AVR programmer, http://www.pololu.com/catalog/product/1300
I have successfully uploaded different programs to the axon2. 
Another note, the LED outputs zero after every upload.

 


Get Your Ad Here