Author Topic: solved!  (Read 4154 times)

0 Members and 1 Guest are viewing this topic.

Offline ying2014Topic starter

  • Beginner
  • *
  • Posts: 1
  • Helpful? 0
« on: March 13, 2014, 06:52:42 AM »
Hello All,
I have a problem using atmel studio 6.1.
Actually, I am just doing a very little programming to the MCU(Atmega 32)  to let the LED blink.

I have connect everything(hardware) and test the wire. I have installed Winavr, avrdude and driver of usbasp.

Here is my step:
1) Open project in Atmel Studio 6.1 and create project(name: ledlightblink) with atmega 32.

2) Rebuild solution(the code is correct).

3) Copy the avrdude.exe to the debug folder of the project.

4) Run cmd, type:
avrdude -e -c usbasp -p m32 -U flash:w:ledlightblink.hex:i

However, errors occur.

avrdude.exe: warning: cannot set sck period. please check for usbasp firmware update.
avrdude:error:programm enable : target doesn't answer.1
avrdude:initialisation failed,rc=-1
I use a lot of time but still canot figure it out. In my friend’s PC, he can program it but in my notebook, it cannot(mine is window 8).
Can you suggest me some ways to solve it. Thanks!!!
« Last Edit: March 13, 2014, 08:49:06 AM by ying2014 »

Offline jwatte

  • Supreme Robot
  • *****
  • Posts: 1,345
  • Helpful? 82
Re: solved!
« Reply #1 on: March 13, 2014, 09:44:05 AM »
Did you plug in the programming cable backwards?