Author Topic: bootloader doesnt work  (Read 1223 times)

0 Members and 1 Guest are viewing this topic.

Offline Mato17Topic starter

  • Jr. Member
  • **
  • Posts: 9
  • Helpful? 0
bootloader doesnt work
« on: July 12, 2011, 01:44:38 AM »
Hi, I'm trying bootloader for my atmega8. I'm using bootloader from tutorial page. I've tried 1.9 and 2.1 version bot none of them works And I dont know where the problem might be.
I'm connecting my mega8 with USB to UART converter and I power my atmega via USB port.
Most weird thing is, that i was able to upload my program once! Just for the first time I've uploaded my hex file successfuly and then, uploading program doesnt work....
I used commands:
FBOOT.EXE -b9600 -c2 -pmain.hex -vmain.hex or FBOOT.EXE /B9600 /C2 /Pmain.hex /Vmain.hex
I've tried to diconnect and reconnect circuit, reboot my computer and also tried linux verson of bootloader and still nothing.

Any hints ?

[EDIT]: I almost forgot, this is high fuse : 0b11011000 I found that right most bit is BOOTRST and it was set to 1 I changed it to 0 maybe theres problem...
« Last Edit: July 12, 2011, 01:56:38 AM by Mato17 »


Get Your Ad Here