Author Topic: AVRStudio simulator hangs  (Read 2071 times)

0 Members and 1 Guest are viewing this topic.

Offline WebbotTopic starter

  • Expert Roboticist
  • Supreme Robot
  • *****
  • Posts: 2,165
  • Helpful? 111
    • Webbot stuff
AVRStudio simulator hangs
« on: October 07, 2009, 11:35:34 AM »
Version 4.16 Build 628

I am currently having problems trying use the simulator to debug a piece of code for the Axon (its worked in the past).

I can compile the program but when I launch the debugger then AVRStudio seems to hang with the CPU at 90%. The debugging windows don't open.

The project options are set up to use the simulator, and ATMega640 at 16MHz.

I have tried:
  • un-installing and re-installing AVRStudio - including telling it to remove all the registry entries during the un-install
  • deleting the project files and rebuilding from scratch
  • rebooting my pc
but all to no avail !

Anyone else had the same problem?

Have tried searching AVR Freaks as well - but can't find anything similar.

Help !
Webbot Home:
WebbotLib online docs:
If your in the neighbourhood:

Offline Admin

  • Administrator
  • Supreme Robot
  • *****
  • Posts: 11,703
  • Helpful? 173
    • Society of Robots
Re: AVRStudio simulator hangs
« Reply #1 on: October 07, 2009, 05:53:38 PM »
I'm not using the simulator so couldn't comment but . . .

v4.17 is out. Try it out, might work:


Get Your Ad Here