Author Topic: $50 robot , AVR programmer mkII and two green lights but not connecting.  (Read 5066 times)

0 Members and 1 Guest are viewing this topic.

Offline Andrew_WaltfeldTopic starter

  • Jr. Member
  • **
  • Posts: 8
  • Helpful? 0
So, Here is my problem:

I have the AVR programmer mkII, with the USB... fire wire, i think it is called.

edit - (sorry, the connection to the CIRCUIT board is 6 prong) -

 I'm not quite sure what to call the connection, but it looks like a fire-wire to me, tried to look it up on Google, but could not find it.

My mini laptop recognizes the programmer and installed all drivers correctly.

I have two green lights on the programmer, I hooked up my motor's (no wheel's are attached yet, so it can't try to suicide off the table), and one of the photo-sensors, and as you can probably tell, i had to do some really really ghetto wiring on the circuit board. Accidentally put the micro-controller on backwards, but it works as far as i can tell with my multi-meter when i spent a hour testing each part.

Now when i click in AVR studio four, I'm basically re-built the program etc and according to the tutorial i can now upload the program into the robot correct? When i try to connect to the robot via the USB-whatever, it says it can't connect.

As far as i can tell i followed every single step and attempted to search on the forums for my problem, even spent the time to redo the multi-metering out every strip of solder i put on there to make sure voltage was getting thru etc.

At this point, I'm not quite sure what to do as the tutorial says that since i have AVR studio four and mkII i should be able to upload now correct since i don't need to use ponyProg?
« Last Edit: November 25, 2009, 02:09:31 AM by Andrew_Waltfeld »

Offline airman00

  • Contest Winner
  • Supreme Robot
  • ****
  • Posts: 3,650
  • Helpful? 21
    • - Mechatronics and related
I feel like your ISP frequency is bad.
Check out the Roboduino, Arduino-compatible board!


Offline Joker94

  • Supreme Robot
  • *****
  • Posts: 1,119
  • Helpful? 26
well for me, i made the hex file in avr studio and also programmed using avr studio as well. 

airman00 could be right about the frequency.

Offline Andrew_WaltfeldTopic starter

  • Jr. Member
  • **
  • Posts: 8
  • Helpful? 0
I feel like your ISP frequency is bad.

ISP Frequency? Well When I press connect, I don't even get that second dialog box that your link has, only the dialog box that lets you select what type of programmer you have. =/ so is that a separate dialog box I am suppose to access from somewhere else? I am assuming that isn't the case according to the link, but I want to double check.

A thought occurred to me -
Does each pin of the micro controller have to be separated? even if they aren't being used for anything? Due note that the pins are on this one are opposite, since i accidentally soldered the mirco-controller backward, so the reset pin is on the right, not left. (so 5 pin headers are on the right side of the board, 6 pin on the left.)

I tried to manage, in the time i had, but was time pressed at the time to get it done.

I don't know if you can see it quite as clearly i can, but this is the best picture i could find. The two bottom pins, of the row of 6 pins that aren't used.

I didn't bother checking the voltage on them since they aren't connected to any circuits. However, since i am new to soldering and circuit boards, will them being connected be any problem at all?

« Last Edit: December 02, 2009, 10:58:39 AM by Andrew_Waltfeld »

Offline Miles

  • Full Member
  • ***
  • Posts: 49
  • Helpful? 1
For starters i don't think you soldered in pin1 (reset) to the programing headers. I had a problem connecting the same programmer through AVR Studio but i fixed it by downloading and installing the latest version of AVR Studio. I read somewhere that i had to do that (maybe in the help section in AVR Studio)

Offline Proctor

  • Jr. Member
  • **
  • Posts: 10
  • Helpful? 0
I'm having the same problem. Two green lights but can't connect my avrisp mkii programmer to avr studios. "connection failed". IT doesnt even give me the opportunity to change the isp frequency because the second dialog box doesnt come up. I've been stuck on this problem for a week now and its driving me crazyy. Since this is my first robot I really wish I had someone to help me  :'(


Get Your Ad Here